Недавно компания Google выпустила Android P Developer Preview — первую сборку новой ОС для разработчиков. А теперь в Reddit появилась информация, что в будущем релиза возможны проблемы с устаревшими программами.

Что известно

В последней сборке указано, что минимально допустимый уровень API для сборки Android P Developer Preview равен v17, что соответствует Android 4.2. Проще говоря, тот софт, который использует более низкую версию API, не будет работать в новой ОС.

В компании предложили обратиться к разработчикам программ, чтобы те обновили версии с учётом новых требований.

Чем это грозит

Возможно, что и ничем серьёзным. С момента выхода Android 4.2 весь популярный софт многократно обновлялся, так что если какие-то программы не обновлены, скорее всего они попросту уже неактуальны. Также не исключено, что предупреждение носит сугубо информационный характер, а не является жёстким запретом.

Наконец, в августе 2019 года планируется начало перехода на 64-битные приложения на Android. Возможно это ещё одна причина появления такого предупреждения.